Хотя плагины предоставляют большую гибкость WordPress, иногда они также подвергают риску веб-сайты из-за их недостатков в безопасности. В прошлом месяце мы видели, что тема Jupiter и ее плагины были критически уязвимы. И теперь Ninja Forms, один из самых популярных разработчиков перетаскиваемых форм, подвергает веб-сайты риску.

Плагин был обновлен принудительно

Ninja Forms выпустила принудительное обновление для своих пользователей, чтобы исправить критическую уязвимость в своем коде. Уязвимость существует в 3.0 и более поздних версиях Ninja Forms, и она исправлена в версии 3.6.11, которая была принудительной версией. Недостатком является уязвимость при внедрении кода, которая позволяет злоумышленникам полностью захватить веб-сайты, используя несколько цепочек эксплуатации.

Ninja Forms — очень популярный плагин, который в настоящее время имеет более 1 миллиона установок. Хотя разработчики выпустили принудительное обновление для плагина, мы рекомендуем вам проверить, является ли он актуальным (3.6.11) или нет. Если процесс принудительного обновления каким-то образом не удался, это означает, что ваш сайт WordPress подвергается большому риску. В этом случае вам следует обновить плагин вручную через панель управления плагинами в интерфейсе администратора WordPress.